Инструменты пользователя

Инструменты сайта


odg_assist_5.0:модуль_обучение

Это старая версия документа!


Содержание

Обзор модуля обучение

Модуль Обучение состоит из 2 модулей:
"Настройки обучения" и "Обучение".

Работа с модулем начинается с настройки обучения.

<color #708090> ** Описание подпунктов "Настройки обучения". ** </color>

<color #2F4F4F> // "Типы обучения" // </color> - пункт меню для добавления типов обучения. Предусмотрено два варианта обучения:

  1. "Самостоятельное" - обучающийся сам изучает предоставленный ему материал и проходит тестирование онлайн.
  2. "Несамостоятельное" - обучение проходит в реальном в режиме с посещением лекции\лекций.

<color #2F4F4F> //"Группы тем обучения" // </color> - пункт меню для редактирования справочника. Позволяет объединять темы обучения в одну группу (по тематике, сфере, должности и т.д). Группа более крупная единица, чем тема.

<color #2F4F4F> //"Разделы обучения" // </color>- пункт меню для редактирования справочника. Справочник содержит области, к которым относится обучение.

<color #2F4F4F> // "Места обучения" // </color> - пункт меню для редактирования справочника. Места, в которых будет проходить несамостоятельное обучение, обучение в реальном режиме.

<color #708090> ** Описание подпунктов "Обучение" ** </color>

<color #2F4F4F> // "Мои обучения" // </color> - содержат записи из тем, требующих ознакомления. Материал для прохождения обучения. Для каждого пользователя могут быть уникальными.

<color #2F4F4F> // "Мои практики" // </color> - записи по обучению. Отображаются по темам с типом практическая работа. Чтобы закрыть записи в "Мои практики", это можно сделать через "Экзамены" либо "Миграция данных по обучению" (заочное закрытие практики, если она уже была пройдена).

<color #2F4F4F> //"Темы обучения" // </color> - пункт меню используется для создания и распределения тем. Доступно сотруднику ответственному за обучение (преподавателю).

<color #2F4F4F> // "Разработка тестов" // </color> - пункт меню используется для создания и хранения тестов, которые можно приложить к теме для обучения.


<color #2F4F4F> // "Программы обучения" // </color> - пункт меню содержит программы, которые состоят из тем. Программы обучения являются неотъемлемой частью "Плана обучения".

<color #2F4F4F> // "Планы обучения" // </color> - пункт меню используется для создания планов обучения. План обучения создается один раз для каждого обучающегося. Содержит информацию о назначенных обучениях и экзаменах. Для 1 -го сотрудника не может быть двух планов. План дополняется по мере необходимости прохождения новых программ обучения.

<color #2F4F4F> // "Экзамены" // </color> - пункт меню содержит реестр всех назначенных и завершенных экзаменах.

<color #2F4F4F> // "Назначение обучения" // </color> - пункт меню позволяет массово назначить программу обучения нескольким пользователям.

<color #2F4F4F> // "Миграция данных по обучению" // </color> - пункт меню открывает доступ к реестру ведомостей обучающихся. Позволяет подгрузить ведомость и список обучающихся и произвести массовый зачет экзаменов, отметки об ознакомлении со всеми выбранными для ознакомления материалами.

<color #2F4F4F> // "Матрица обучения" // </color> - пункт меню содержит сводный реестр по прогрессу обучения всех пользователей.

<color #2F4F4F> // "Архив тем" // </color> - пункт меню предоставляет доступ к реестру архивных тем.

<color #2F4F4F> // "Архив программ" // </color> - пункт меню предоставляет доступ к реестру архивных программ.

<color #2F4F4F> // "Проверка тестов" // </color> - в пункте меню доступны документы с тестами , назначенные пользователю (обучающему) для ручной проверки.

<color #2F4F4F> // "Отчет по обучению" // </color> - пункт меню позволяет сгенерировать отчет по заданному шаблону.

<color #2F4F4F>// "Матрица обучения (new)" // </color> - пункт меню содержит сводный реестр по прогрессу обучения всех пользователей по подразделению

<color #2F4F4F> // "Мои обучения (сгруппированные)" // </color> - содержат записи из тем, требующих ознакомления, в сгруппированном формате. Материал для прохождения обучения. Для каждого пользователя могут быть уникальными.

Макропроцесс "Обучение сотрудников"

Описание настройки справочников и тестов

<color white> Разрыв страницы </color>

Настройка справочника "Типы обучения"


<color #708090> ** Создание типа обучения ** </color>

Нажмите пункт основного меню "Настройки обучения", подпункт "Типы обучения".
Откроется окно "Просмотр типов обучения".

Нажмите кнопку "Создать". Откроется окно "Редактор типов тем обучения". Поля формы не заполнены:

<color white> _ </color>В поле <color #2F4F4F> // "Имя" // </color> ввести название типа обучения. Это могут быть и буквенные и числовые значения.
Поле <color #2F4F4F> // "Самостоятельное обучение" // </color>, если поставить отметку, то обучение будет проходить в онлайн формате.
Обучаемые самостоятельно знакомятся с предоставленными материалами и проходят онлайн тестирование. Если поле оставить пустым, то такой тип обучения будет предполагать реальное посещение лекций обучаемыми и прохождение экзамена в реальном времени.
Нажать "ОК". Окно "Редактор типов тем" обучения закроется. В окне "Просмотр типов обучения" отобразится добавленный тип.

<color #708090> ** Изменение типа обучения ** </color>

<color white> _ </color>В окне "Просмотр типов обучения" кликнуть на строку с типом обучения.
Нажать "Изменить". Откроется окно "Редактор типов тем обучения". Все поля доступны для редактирования. По завершению редактирования, нажмите "Ок".

<color white> Разрыв страницы </color>

Настройка справочника "Группы тем обучения"


Нажмите пункт меню "Настройки обучения", подпункт "Группы тем обучения".
В открывшемся реестре для добавления новой группы нажмите "Создать".

В поле <color #2F4F4F> "Название" </color> введите название группы. Затем нажмите "Ок".

Добавленная группа отобразится в реестре.

<color white> _ </color>Для редактирования имеющейся группы необходимо выбрать ее в реестре. Нажать кнопку "Изменить".

<color white> Разрыв страницы </color>

Настройка справочника "Разделы обучения"


Нажмите пункт меню "Настройки обучения", подпункт "Разделы обучения".

В реестре "Просмотр разделов обучения" нажмите кнопку "Создать".
В отобразившемся окне "Редактор разделов обучения" в поле <color #2F4F4F> // "Имя" //</color> введите название раздела.

По завершению нажмите кнопку "Ок".

<color white> Разрыв страницы </color>

Настройка справочника "Места обучения"


Нажмите пункт меню "Настройки обучения", подпункт "Места обучения".
В реестре "Просмотр мест обучения" нажмите "Создать".
Откроется окно // "Редактор мест обучения". В поле <color #2F4F4F> // "Название локации" </color> введите название места проведения обучения.
Нажмите "Ок".

Окно редактора закроется. В реестре отобразится добавленное место проведения обучения.

<color white> Разрыв страницы </color>

Обучение

Создание темы обучения


Для создания Темы необходимо выполнить следующие шаги:
Нажмите на пункт меню «Обучение», подпункт «Темы обучения». Далее нажмите кнопку «Создать» в реестре тем.

<note>

Создание темы возможно только под определенной ролью (Администратор модуля обучения).

</note>

В открывшейся форме «Редактирование темы обучения» необходимо заполнить поля.
<color white> _ </color> Поля, выделенные серым цветом недоступны для редактирования и заполняются системой автоматически в процессе и/или после прохождения процесса согласования темы.
Недоступные к редактированию поля:

  • <color #2F4F4F> //"Код темы" // </color>
  • <color #2F4F4F> //"Версия" // </color>
  • <color #2F4F4F> //"Статус" // </color>

<color white> _ </color> Поля, обязательные к заполнению для запуска процесса согласования системы.
Обязательные к заполнению поля:

  • <color #2F4F4F>"Тип темы" // </color> * <color #2F4F4F>"Периодичность ознакомления"// </color>
  • <color #2F4F4F>"Название темы" </color>
  • <color #2F4F4F>"Дата разработки темы" </color>
  • <color #2F4F4F>"Раздел" </color>
  • <color #2F4F4F>"Способ предоставления обучающего материала" </color>
  • <color #2F4F4F>//"Способ хранения тестового материала" // </color>

<color #708090> Описание заполнения атрибутов (полей) темы обучения. </color>

<color #2F4F4F>// "Название темы"// </color> – текстовое поле. Название темы обучения имеет ограничение в 500 символов.

<color #2F4F4F>// "Тип темы"// </color> – поле единичного выбора. На выбор несколько вариантов:

  • Теоретическое обучение — при таком выборе требуется указать материал хранящийся в системе или загрузить его. После ознакомления с материалом пользователь при необходимости может пройти тест.
  • Практическое обучение — Практика проводится преподавателем.

<color #2F4F4F>// "Периодичность ознакомления"// </color> – поле единичного выбора. Варианты выбора:

  • "Разовая"
  • "Повторяющаяся" – при указании выбора в поле будет отображено дополнительное скрытое поле <color #2F4F4F>«Период ознакомления».</color>

Для его заполнения нажмите на иконку «Лупа». Откроется окно «Редактор периодичности». В редакторе три поля для заполнения:

  • <color #2F4F4F>"Тип периода" //</color> - (тип единичный выбор), на выбор следующие варианты: - секунды - дни - месяцы * <color #2F4F4F>"Тип расчета" // </color> - (тип единичный выбор), на выбор следующие варианты:
    1. «От даты назначения»
    2. «От даты прохождения темы сотрудником»
    3. «От даты утверждения темы»

<color white> _ </color> Для корректной работы периодического ознакомления с темой требуется настроить "Рутину". Для этого нужно обратиться к администратору приложения или в службу поддержки OdgAssist.

<color #2F4F4F>"Дата разработки темы"</color> - поле с типом дата, не допускается указание прошедшей даты.

<color #2F4F4F>"Раздел"</color> - тип поля единичный выбор. Варианты на выбор должны быть предварительно настроены в справочнике "Разделы обучения".

<color #2F4F4F>"Способ предоставления обучающего материала"</color> - поле единичного выбора. Варианты выбора:

  • "В системе" — вариант выбора отобразит скрытое поле "Обучающий документ". Поле позволяет указать документ, уже имеющийся в системе в качестве учебного материала.
  • "В файле" — вариант выбора отобразит дополнительное поле "Файл обучающего материала", поле позволяет загрузить в систему файл с обучающим материалом. Тип файла текстовый, например pdf, docx, pptx.
  • "Без материала" — варианты выбора не отображает никаких дополнительных полей.
  • "Видео" — вариант выбора отобразит дополнительное поле "Файл обучающего материала", поле позволяет подгрузить видео файл по теме обучения в формате mp4, mov.

<color #2F4F4F>"Способ хранения тестового материала"</color> - поле содержит несколько вариантов на выбор:

  • "Без файла"
  • "В файле" — при выборе отобразится дополнительное поле для загрузки файла.
  • "В системе" — при таком выборе будет предложено добавить шаблон теста. Создание теста будет рассмотрено в отдельной главе "Разработка тестов".

<color #2F4F4F>//"Менеджер по обучению" //</color> - поле для указания пользователя ответственного за обучение сотрудников. (Пользователь, который следит за сроками бучения, создания тем и программ.)

<color #2F4F4F>"Согласующие"</color> – пользователи ответственные за согласование темы

<color #2F4F4F>"Утверждающие"</color> – пользователи ответственные за утверждение темы

<color #2F4F4F>"Настройка распределения"</color> - выбрать тип распределения темы в одном из предложенных вариантов. Или отметить галочкой <color #2F4F4F>«без распределения»</color>, если не требуется распределение для темы.

  • Закладка "Подразделение" – данная тема может быть добавлена в программу обучения для конкретного подразделения или подразделений. Возможен выбор нескольких подразделений для одной темы из реестра «Подразделения».
  • Закладка "Должности" – данная тема может быть добавлена в программу обучения по распределению по указанной должности. Возможен выбор нескольких должностей для одной темы из реестра «Должности».
  • Закладка "Роли" – данная тема может быть добавлена в программу обучения по распределению по указанной роли. Возможен выбор нескольких ролей для одной темы из реестра «Ролей».

Для добавления типа распределения нажать на кнопку "Добавить", в закладке. В открывшемся реестре выбрать один или несколько элементов для добавления. После выбора подтвердить нажатием кнопки «Выбрать». При ошибочном выборе элемента возможно удалить лишние позиции нажатием кнопки «исключить».

<color #2F4F4F>"Тема для замены" </color> - при добавлении тем в поле «темы для замены», выбранные темы заменяются создаваемой темой после утверждения создаваемой темы.

<color #2F4F4F>"Комментарии" </color> - При необходимости оставить комментарии в поле <color #2F4F4F>«Комментарии». </color>

При необходимости добавления других файлов нажмите на закладку «Дополнительные материалы», затем кнопку «Загрузить» добавить дополнительные материалы.

<color white> _ </color> Кнопка "Сохранить как черновик" позволяет сохранить прогресс заполнения карточки и вернуться к заполнению позже.
В случае нажатия кнопки "Отмена" окно редактора тем будет закрыто и информация из заполненных полей удалена.
Нажатие кнопки "Отправить на согласование" запустит процесс согласования темы.

Диаграмма процесса согласования темы обучения:

Задачу "Рецензирование" выполняет менеджер по обучению.

Задачи "Согласование" и "Утверждение" не будут активны, если в карточке темы заполнены следующие поля с указанным выбором:

  • <color #2F4F4F>"Тип темы" // </color> → //"Практическое обучение"
  • <color #2F4F4F>"Способ предоставления обучающего материала" // </color> → //"Без материала"
  • <color #2F4F4F>"Способ хранения тестового материала"</color> → "Без материала"

<color white> Разрыв страницы </color>

Разработка тестов


Нажмите пункт меню "Обучение", подпункт "Разработка тестов".
Отобразится форма "Редактор тестов". В форме необходимо заполнить поля.

<color #708090> Описание полей формы "Редактор теста". </color>

<color #2F4F4F> // "Название" // </color> - текстовое поле, допускается имя длиной не более 255 символов.

<color #2F4F4F> "Номер версии" </color> - поле поддерживает ввод и хранение только числовых значений.

<color #2F4F4F> "Количество вопросов в тесте" </color> - поле поддерживает ввод и хранение только числовых значений. Количество вопросов, указанное в этом поле будет взято из общего списка вопросов для тестирования пользователя. Вопросы будут взяты рандомно из списка всех вопросов теста.

<color #2F4F4F> // "Тип проверки" // </color> - поле единичного выбора. Несколько вариантов на выбор:

  • "Ручная проверка" — при выборе отобразится дополнительное поле "Проверяющий". В поле необходимо выбрать сотрудника, ответственного за проверку теста.

<color #2F4F4F> "Вопросы теста" </color> - поле список. Для добавления вопроса нажмите кнопку "Создать". В отобразившемся окне "Редактор шаблона вопроса" заполните поле <color #2F4F4F> "Вопрос"</color>. Также вопрос может содержаться в файле. При необходимости можно загрузить изображение, нажав кнопку "Загрузить" в поле <color #2F4F4F> "Изображение"</color>.
Для удаления, просмотра или изменения вопроса выберите его в списке и нажмите соответствующую кнопку.
По завершению заполнения полей нажмите кнопку "Ок".

  • "Автоматическая проверка" — при выборе отобразится дополнительное поле "Процент прохождения".

<color #2F4F4F> "Процент прохождения" </color> - числовое поле (от 1 до 100) для установки количества правильных ответов (в процентах от общего количества) в тесте для присвоения статуса теме «Сдан».

Для типа проверки "Автоматическая проверка", форма "Редактор шаблона вопроса" имеет отличие:
Требуется заполнить дополнительное поле <color #2F4F4F> "Ответы"</color>.

Для добавления ответа нажмите кнопку "Создать". Заполните форму "Редактор шаблона ответа". Введите ответ в поле <color #2F4F4F> "Текст ответа"</color>. При необходимости добавьте изображение, нажав кнопку загрузить в поле <color #2F4F4F> "Изображение"</color>. В случае, если добавляемый ответ верный установите отметку в поле <color #2F4F4F> "Данный ответ правильный"</color>.
Для изменения или удаления ответа, выберите его в списке ответов и нажмите соответствующую кнопку.
После заполнения всех полей нажмите кнопку "Ок".

<color white> Разрыв страницы </color>

Создание программы обучения


Для создания Программы обучения нажмите пункт меню "Обучение", подпункт "Программы обучения".
В открывшемся реестре "Программы обучения" нажмите кнопку "Создать".
Отобразится окно "Редактор программы обучения".
Необходимо заполнить поля редактора.

<color #708090> ** Описание полей формы "Редактор программы обучения". ** </color>

Поля недоступные к заполнению: <color #2F4F4F> // "Код", "Версия", "Статус" // </color>
Поля обязательные к заполнению для запуска процесса согласования системы:
<color #2F4F4F>"Тип программы", "Тип распределения", "Должность", "Роль", "Подразделение", "Менеджер по обучению"</color>

<color #2F4F4F>"Тип программы"</color> - поле единичного выбора. Несколько вариантов на выбор:

  • Первичное
  • Последующее

<color #2F4F4F>"Название программы"</color> - текстовое поле, название программы не более 255 символов

<color #2F4F4F>"Тип распределения тем"</color> - поле единичного выбора. Несколько вариантов на выбор:

  • По роли
  • По должности
  • По подразделению

<color #2F4F4F>"Должность"</color> - в случае выбора типа распределения "по должности" в поле "Тип распределения тем", необходимо заполнить это поле. Нажмите на иконку "Три точки". В открывшемся реестре выберите требуемое.

<color #2F4F4F>"Роль"</color> - в случае выбора типа распределения "по роли" в поле "Тип распределения тем", необходимо заполнить это поле. Нажмите на иконку "Три точки". В открывшемся реестре выберите требуемое.

<color #2F4F4F>"Подразделение"</color> - в случае выбора типа распределения "по подразделению" в поле "Тип распределения тем", необходимо заполнить это поле. Нажмите на иконку "Три точки". В открывшемся реестре выберите требуемое.

<color #2F4F4F>"Менеджер по обучению"</color> – в поле необходимо указать пользователя, ответственного за обучение, создание тем и программ по обучению. Для выбора пользователя нажмите на иконку "Три точки", в открывшемся реестре пользователей выберите пользователя.

<color #2F4F4F>"Согласующие"</color> – пользователи, ответственные за согласование программы обучения. Для добавления пользователей нажмите кнопку "Добавить". Выберите пользователя в реестре. Для удаления пользователя из списка "Согласующие" выберите его и нажмите "Исключить".

<color #2F4F4F>"Утверждающие"</color> – пользователи, ответственные за утверждение программы обучения. Для добавления пользователей нажмите кнопку "Добавить". Выберите пользователя в реестре. Для удаления пользователя из списка "Утверждающие" выберите его и нажмите "Исключить".

<color #2F4F4F>"Темы"</color> - поле для добавления тем в программу обучения. Нажмите кнопку "Добавить" и выберите тему в реестре "Темы обучения." Для удаления ошибочно добавленной темы, выберите ее и нажмите "Исключить". Для просмотра темы, выберите ее в списке и нажмите кнопку "Просмотр". Кнопка "Обновить темы" - автоматическое добавление. По нажатию система автоматически добавит все темы с таким же типом распределения как указан в поле "Тип распределения тем".

<color white> _ </color>При необходимости можно прервать работу над программой и вернуться к ней позже, для этого нажмите "Сохранить как черновик".
Нажатие кнопки "Отмена" закроет редактор программы обучения, информация, внесенная в поля, не сохранится.
Нажатие "Отправить на согласование" запустит процесс согласования программы обучения.

Диаграмма процесса согласования программы обучения:

<color white> Разрыв страницы </color>

Добавление плана обучения


План обучения создается для каждого сотрудника 1 раз. Для добавления плана нажмите пункт меню "Обучение", подпункт "Планы обучения". Далее в реестре "Планы обучения" нажмите кнопку "Создать".

На вкладке "Программы обучения" заполните поля.

<color #2F4F4F> // "Статус" // </color> - поле единичного выбора. На выбор два варианта:

  • "В работе"
  • "Архив"

<color #2F4F4F> // "Студент" // </color> - нажмите на иконку "Три точки". В реестре пользователей выберите сотрудника для которого создается план.

<color #2F4F4F> // "Руководитель сотрудника" // </color> - при выборе студента, поле "Руководитель сотрудника" заполнится автоматически. Руководителя можно сменить, нажав на иконку "Три точки". В реестре пользователей выбрать требуемого пользователя.

<color #2F4F4F> // "Дата приема/перевода на работу" // </color> - поле с типом дата.

<color #2F4F4F> // "Добавить программу обучения" // </color> - кнопка для выбора программ обучения. По нажатию откроется реестр "Программы обучения". Выберите программу в реестре и нажмите "Выбрать". Реестр закроется, выбранная программа отобразится в плане обучения сотрудника.

<color #2F4F4F> // "Запустить ознакомление по выбранным программам" // </color>. Кнопка запускает программу обучения
выбранную в плане. Перед запуском программы обучения необходимо откорректировать даты начала обучения и крайнего срока.
Для этого выберите программу в плане и нажмите кнопку "Изменить". Заполните поля:

  • <color #2F4F4F> "Крайний срок" </color>.
  • <color #2F4F4F> "Дата начала обучения" </color>.

<color white> Разрыв страницы </color>

Моё обучение


Для прохождения ознакомления с материалом нажмите пункт меню "Обучения", подпункт "Мои обучения".
Откроется реестр программ обучения. Программа обучения может содержать несколько тем для ознакомления. Раскройте необходимую программу и выберите тему для ознакомления. Нажмите "Открыть".

Окно "Редактор ознакомления"

Откроется вкладка "Редактор тем ознакомления". Для ознакомления с материалом нажмите "Ознакомиться".
В новой вкладке "Предпросмотр" откроется документ для ознакомления с постраничным отображением. Для перехода между страницами используйте кнопки "Вперед", "Назад".
По окончанию ознакомления закройте вкладку "Предпросмотр".
<color white> _ </color> В случае если тема содержит тест, будет доступна кнопка "Выполнить тест".
По нажатию откроется вкладка "Прохождение теста". Ответьте на вопросы. Введите свой ответ в поле <color #2F4F4F> // "Ответ" // </color> и нажмите кнопку "Ответить". После ответа на все вопросы нажмите "Отправить на проверку". <color white> _ </color> В случае если тест с ручной проверкой. Проверка будет осуществлена пользователем ответственным за обучение. После проверки теста и его прохождения для темы будет установлена отметка "Ознакомлен", "Пройден".
При автоматической проверке теста и его прохождении, пройденная тема с тестом пропадает из реестра "Мои обучения", после отправки ее на проверку.
<color white> _ </color> При неуспешном прохождении теста, его потребуется пройти повторно.
Откройте запись с темой. В окне "Редактор ознакомления" отобразится новая запись для прохождения тестирования. По не сданному тесту в колонке "Статус" будет указано "Отклонено".

В реестре не отображаются версии документов, которые переведены в статус "Архив". <color white> Разрыв страницы </color>

Моя практика


Пункт меню позволяет обучающемуся отслеживать предстоящие практические занятия.
Для просмотра предстоящих практик перейдите в пункт меню "Обучение", подпункт "Моя практика".
Откроется реестр практик. Вы не можете ничего изменить или редактировать в этом реестре. Он носит информирующий характер.

<color white> Разрыв страницы </color>

Проведение практического занятия


Задачу выполняет сотрудник ответственный за обучение (преподаватель).
Для проведения практической работы нажмите пункт меню "Обучение", подпункт "Миграция данных по обучению".

Заполните поля карточки:

  • <color #2F4F4F> // "Причина" // </color>
  • <color #2F4F4F> // "Тип" // </color> Варианты на выбор:
    • "Темы" - для этого выбора будет отображено поле <color #2F4F4F> // "Темы" // </color>. Потребуется выбрать темы для практической работы, используя кнопку "Добавить".
    • "Программы обучения" - для этого выбора будет отображено поле <color #2F4F4F> // "Программы обучения" // </color>. Потребуется выбрать программы обучения для практической работы, используя кнопку "Добавить".
    • "Документы" - для этого выбора будет отображено поле <color #2F4F4F> // "Версии документов" // </color>. Потребуется выбрать версии документов для практической работы, используя кнопку "Добавить".
  • <color #2F4F4F> // "Ведомости" // </color> - например явка пользователей на практику. Сканы работ и т.д.
  • <color #2F4F4F> // "Обучаемые" // </color> - для добавления обучаемых сотрудников нажмите "Добавить списком", выберите пользователей в реестре "Пользователи". Для выбора нескольких пользователей из реестра используйте клавишу Ctrl.

Для добавленных пользователей необходимо указать фактическую дату проведения практической работы в поле <color #2F4F4F> // "Дата ознакомления" // </color>. После установки даты нажать кнопку "Установить дату для выбранных пользователей". По завершению работы над карточкой нажмите "Подтвердить обучение".

У обучаемого пользователя после завершения практической работы в реестре "Мои практики" будет удалена запись по пройденной теме/программе или версии документа.

<color white> Разрыв страницы </color>

Проведение практической работы

Для сдачи практической работы нажмите пункт меню "Обучение", подпункт "Экзамены".

На вкладке "Окно экзамена" в поле <color #2F4F4F>"Тип"</color> выберите вариант "Практическая работа". Укажите дату и место проведения планируемой практической работы в полях <color #2F4F4F> "Планируемая дата экзамена", "Место проведения экзамена" </color>.

Укажите экзаменуемого в поле <color #2F4F4F> // "Экзаменуемые"// </color>, используя кнопку "Добавить". Добавьте пользователей в поле <color #2F4F4F> // "Комиссия"// </color>. После заполнения всех полей нажмите "Запустить процесс".

Процесс проведения экзамена и практического занятия:

<color #708090>Выполнение задачи "Подтверждение экзамена".</color>
Нажмите пункт меню "Обучение", подпункт "Экзамены". Выберите запись в реестре и нажмите "Открыть".
Заполните поля:

  • <color #2F4F4F> // "Фактическая дата экзамена" // </color>
  • <color #2F4F4F> // "Экзаменуемые" // </color> - в поле необходимо выбрать пользователя и кнопкой отметить необходимый вариант:
    1. Сдал
    2. Не сдал
    3. Не пришел
  • <color #2F4F4F> // "Ведомости" // </color>

Далее нажать "Завершить задачу".

<color #708090>Выполнение задачи "Принятие решения о допуске сотрудника".</color>

Нажмите пункт меню "Обучение", подпункт "Экзамены". Выберите запись в реестре и нажмите "Открыть".
В поле <color #2F4F4F> // "Экзаменуемые" // </color> выберите пользователя и нажмите кнопку, соответствующую вашему решению.
Кнопки для принятия решения по результатам практической работы (заполняется руководителем обучаемого):

  • Допустить
  • Не допустить

В случае нажатия "Допустить", статус решения для пользователя сменится на "Допустить к самостоятельной работе".

<color white> Разрыв страницы </color>

Ручная проверка тестов


Проверку тестов проводит пользователь, указанный в поле "Проверяющий" в форме "Редактор теста".

Для проверки выполненных тестов нажмите пункт меню "Обучение", подпункт "Проверка тестов".
Откроется реестр тестов для проверки. Выберите тест и нажмите "Изменить". Откроется форма "Редактирование формы обучения". В поле <color #2F4F4F> // "Вопросы" // </color>, выберите вопрос и нажмите "Изменить".

Для просмотра ответа нажмите на иконку "Лупа" для просмотра ответа пользователя.
В форме "Редактор ручной проверки знаний" для верного ответа поставьте отметку в поле <color #2F4F4F> // "Результат" // </color>. Для неверного ответа оставьте поле <color #2F4F4F> // "Результат" // </color> пустым и добавьте комментарий. По завершению проверки тестов нажмите "Принять" или "Отклонить".

<color white> Разрыв страницы </color>

Создание экзамена


Нажмите пункт меню "Обучение", подпункт "Экзамены".
На вкладке "Экзамены" нажмите кнопку "Создать".

На вкладке "Окно экзамена" заполните поля карточки:

<color #2F4F4F> // "Тип" // </color> - установите "Экзамен".
<color #2F4F4F> // "Планируемая дата экзамена" // </color> - дата должна быть в будущем.
<color #2F4F4F> // "Место проведения экзамена" // </color>
Для заполнения полей "списков" используйте кнопку "Добавить". При множественном добавлении используйте клавишу Ctrl при выборе элементов в реестре выбора.
<color #2F4F4F> // "Программы обучения" // </color>
<color #2F4F4F> // "Экзаменуемые" // </color>
<color #2F4F4F> // "Комиссия" // </color>.

<note>

Если у выбранных вами пользователей есть незавершенные экзамены по текущей программе экзамена или у пользователя нет плана обучения, система отобразит соответствующее сообщение.

</note>


 карточка экзамена

По завершению заполнения карточки нажмите "Запустить процесс". В случае если требуется прерваться на время от заполнения карточки, нажмите "Сохранить как черновик". Информация, внесенная в карточку, будет сохранена.

<color white> Разрыв страницы </color>

Сдача экзамена


Экзамен проводится в системе через процесс.

После создания карточки экзамена запускается процесс.

<color #708090>// Задача "Подтверждение экзамена". //</color>

Исполнитель: пользователь, заполнявший карточку.

Заполните поле <color #2F4F4F> // "Фактическая дата экзамена"// </color>.
Выберите пользователя в поле<color #2F4F4F> // "Экзаменуемые" // </color> и отметьте результат экзамена или неявку. Загрузите ведомость в поле<color #2F4F4F> // "Ведомости" // </color>. Затем нажмите "Завершить задачу".

<color #708090>// Задача "Принятие решения о допуске сотрудника". //</color>

Исполнитель: руководитель экзаменуемого пользователя.

В поле <color #2F4F4F> // "Экзаменуемые" // </color> выберите пользователя и отметьте решение по допуску используя кнопки: "Допустить" или "Не допустить".
Затем нажмите "Завершить задачу".

В случае не сдачи экзамена, "Экзаменуемые" проходят его повторно.
Новая запись с экзаменом по несданной программе создается автоматически.

Миграция данных по обучению


Миграция данных позволяет произвести зачет программы обучения для пользователей не имеющих доступа к системе. Зачет программы производится офлайн. Миграция только фиксирует время реального прохождения обучения по программе, подтверждением служит приложенная ведомость.
Для проведения миграции нажмите пункт меню «Обучение», подпункт «Миграция данных по обучению». Нажмите кнопку «Создать». Заполните поля карточки миграции.

Описание полей карточки: Статус – Установите “Черновик”

Причина — укажите причину проведения миграции

Тип — заполните тип обучения.

  • Документ - зачитываются только документы.
  • Тема - зачитываются только темы.
  • Программа - целиком мигрирует программа.

Ведомости — загрузите ведомость, используя кнопку “Загрузить” .
Обучаемые — Для добавления пользователей нажмите “Добавить списком”. Отобразится реестр пользователей. Можно выбрать несколько, для этого зажмите Ctrl и выберите необходимые учетные записи. По окончанию выбора нажмите “Ок”.
Далее установите время и дату для добавленных пользователей.
Для этого установите необходимую дату и время в поле “Обучаемые”.
Выберите пользователей зажав CTRL, затем нажмите кнопку “Установить дату для выбранных пользователей”. Нажимать кнопку необходимо пока у всех выбранных пользователей не заполнится колонка “Дата ознакомления”.

Затем нажмите кнопку “Подтвердить обучение”. Обучение по которому проведена миграция не будет отображаться у пользователей в пункте “Мои обучения”.

Поведение системы при различных условиях:
1. Программа назначена в план обучения пользователя и запущена. После проведения миграции:
- Все элементы программы у пользователя закроются. (Не будут отображаться в подпунктах "Мои обучения", "Мои практики") - Статус программы изменится на “Программа завершена”. - Сдавать экзамен пользователю не требуется.

2. Программа обучения назначена пользователю, но не запущена После проведения миграции:
- Статус программы изменится на “Программа завершена”. - Сдавать экзамен пользователю не требуется.

3. Программа не назначена в план обучения сотрудника. После проведения миграции:
- Программа добавится в план обучения сотрудника со статусом “Программа завершена”. - Сдавать экзамен пользователю не требуется.

Почтовые Уведомления модуля "Обучение"

Уведомление: "О необходимости пройти ознакомление по теме (документу)"
Метод: ''ru.od.odgassist_5.core.NotificationBean#notificationAboutAcknowledgement ''
Когда отправляется:

  • При создании ознакомления
  • При несдаче теста

Кто получает уведомление: пользователь на которого назначено ознакомление

Уведомление: "Оповещение руководителей о статусе прохождения сотрудниками программ"
Здесь учитываются все что не в статусе "Программа завершена".
Метод: '' ru.od.odgassist_5.service.TasksReportServiceBean#notifyTutorsAboutOverdueStudy ''
Когда отправляется: настраивается в пункт меню "Назначенные задания"
Кто получает уведомление: руководители сотрудников (из плана обучения)

Уведомление: "О необходимости провести обучение"
Метод: ru.od.odgassist_5.service.NotificationServiceBean#scheduleTeaching
Когда отправляется: когда планируется Назначение обучение
Кто получает уведомление: Преподаватель из Назначения обучения

Уведомление:
Метод: ru.od.odgassist_5.service.NotificationServiceBean#notifyTutorsAboutBadExam
Когда отправляется: вызовов в коде нет, вызов в диаграмме
Кто получает уведомление: руководители сотрудников (из плана обучения)

Формирование отчета по планам обучения


Для формирования отчета по обучению необходимо наличие "Плана обучения" у сотрудников по которым формируется отчёт. В планах должны быть пройденные программы и темы.
Для проверки наличия плана обучения у сотрудника, нажмите пункт меню "Обучение ", подпункт "Планы обучения".
Отобразится реестр планов обучения.

Далее нажмите пункт меню "Обучение", подпункт "Отчёты по обучению".
Нажмите кнопку "Создать". Выберите тип. На выбор несколько вариантов:

  • По подразделению
  • По Пользователю
  • Настроен вручную

Далее откроется окно редактор отчета
Заполните поля и нажмите кнопку "Сформировать отчет".

Роли для настройки модуля


Роль: Администратор модуля обучение

администратор_модуля_обучение.zip

Роль: Ответственный за обучение

ответственный_за_обучение.zip

Роль: Согласующий и утверждающий обучение

согласующий_и_утверждающий_обучение.zip

Роль: Пользователь обучение

пользователь_обучение.zip

Выгрузка отчета из матрицы обучения new

Выгрузка отчета в матрице обучения new в файле со следующей информацией:

* Название
* Код
* Версия
* Статус
* Дата создания
* Список тем (Название, Код)
* Список документов (Название, Код)
* Версия документа (опционально)
Для выгрузки отчета необходимо произвести следующие действия:

1. Открыть раздел "Матрица обучения new"
2. Выбрать из списка подразделений нужное
3. Отфильтровать по следующим критериям, установив на против нужного флаг/галочку:
*Установить флажок - только последние версии документов
*Установить флажок - только по программам обучения
*Установить флажок - только активных пользователей

4. нажать на кнопку "отчет"
5. перейти в раздел "отчеты по обучению", в реестре данного раздела найти сформированный отчет под вашим логином.

Администрирование модуля

(для сотрудников с правами администратора)

1. Удаление программы обучения

Для удаления программы обучения пользователя в системе, необходимо перейти в модуль «Обучение», раздел «Планы обучения» и выбрать нужного сотрудника.

Далее, в плане обучения необходимо выбрать нужную программу обучения, назначенную сотруднику и нажать на кнопку «Удалить» (все ознакомления и связанные с ними элементы так же будут удалены).

2. Удаление ознакомлений

Для удаления элементов обучения на вкладке «Ознакомления» в плане обучения сотрудника, необходимо перейти в модуль «Обучение» раздел «Планы обучения» и выбрать нужного сотрудника.

В плане обучения перейти на вкладку «Ознакомления», найти нужную программу обучения, раскрыть список с вложенными элементами, выбрать требуемый элемент для удаления и нажать кнопку «Удалить»

3. Удаления документов из плана обучения

Для удаления документов (в том числе старых версий) в плане обучения сотрудника, необходимо перейти в модуль «Обучение» раздел «Планы обучения» и выбрать нужного сотрудника.

В плане обучения перейти на вкладку «Документы», выбрать требуемый документ для удаления и нажать кнопку «Удалить»

<note>

При удалении документа через вкладку «Документы», ознакомление по нему так же удаляется.

При удалении ознакомления через вкладку «Ознакомления», удаляется только ознакомление. Администратор системы (admin) в редакторе плана обучения может выборочно удалять элементы областей: "Программы обучения" (только в статусе прохождения "В процессе обучения"), "Темы" и "Документы".

</note>

===== FAQ =====—- Вопрос:
Почему отображается разное количество версий документов на ознакомление в реестре "Мои обучения" и в плане обучения сотрудника?
Ответ:
В реестре "Мои обучения" отображаются версии документов только в статусе "Согласован".
А в плане обучения сотрудника, на вкладке "Ознакомления" отображаются все версии документов добавленных на ознакомление. Статус версии документа не влияет на отображение.

Часто задавыемые вопросы

Вопрос.

<note>

Пользователь ознакомился со всеми документами и сдал всю теорию (теоритические темы), в плане обучения оставалась только практика (практические темы), однако статус программы почему то не сменился на "допущен с ограничениями".

</note>

Ответ.

<note>

Каждый раз при изменении плана действий (создание ознакомления) запускается проверка на то какие статусы должны быть в программе обучения, в зависимости от прохождения пользователем обучения по заданной программе. Проверка не проводится, в случае если программа находится в статусе "необработана" или если она в статусах прохождения "программа закончена" или "неактуально", в отношении любых других статусов проверка проводится.

</note>

Примечание* Если статус прохождения программы уже переведен на "Допущен с ограничениями" по случаю ознакомления пользователем со всеми документами и сдачей всей теории кроме практики,
то при изменении плана действий (создание нового ознакомления) вернет статус программы в предыдущее положение "в процессе обучения."

Создание программы обучения с группировкой элементов

Для создания Программы обучения с блоками нажмите пункт меню "Обучение", подпункт "Программы обучения".
В открывшемся реестре "Программы обучения" нажмите кнопку "Создать".
Отобразится окно "Редактор программы обучения".
Необходимо заполнить поля редактора (порядок заполнения описан выше)

Поставить галочку в чек-боксе «Группировать элементы»

Появится таблица "Элементы программы"

В таблице Элементы программы нажмите кнопку «Создать блок». В открывшемся Редакторе элемента заполните поле Название значением «Блок1». Нажмите кнопку «Ок» → В таблицу Элементы программы добавился Блок1.

Выберите Блок1 и нажмите кнопку «Добавить версии документов» и выберите «Тестовый документ», нажмите кнопку «Выбрать» → В Блок1 добавился выбранный документ.

Раскройте Блок1, выберите «Тестовый документ» нажмите кнопку «Удалить» → Документ удалился

В таблице Элементы программы нажмите кнопку «Создать блок». В открывшемся Редакторе элемента заполните поле Название значением «Блок2». Нажмите кнопку «Ок» →В таблицу Элементы программы добавился Блок2

Выберите Блок2 и нажмите кнопку «Изменить» измените название блока на «Блок1.1» → Название блока изменилось

Выберите Блок1.1 и нажмите кнопку «Добавить темы» и выберите тему, которую создали ранее, нажмите кнопку «Выбрать» → В Блок1.1 добавилась выбранная тема обучения

Кнопки "Вверх" и "Вниз" позволяют изменить порядок отображения блоков

Выберите Блок1.1 и нажмите кнопку "Вверх" → Блок 1.1 переместился вверх и изменилось значение в столбце "Порядок"

Раскройте Блок1.1, выберите добавленную тему, нажмите кнопку "Изменить блок" → Появилось окно "Выберите родительский элемент"

В поле "Блок" выберите "Блок1" → Тема переместилась в Блок1

Вид таблицы «Элементы программы»

Таблица «Элементы программы» содержит колонки:

Название, Порядок, Код темы/документа (действительный код темы/версии документа), Версия, Версия документа.

Группировать элементы возможно при:

Создание программы с нуля;
Создание новой версии программы.

Программу с группировкой элементов можно назначить:

через план обучения;
через назначение обучения.

Программы с группировкой элементов отображаются в разделе Мои обучения (сгруппированные).

Создание новой версии программы с группировкой элементов (старая версия программы без группировки)

Выберите утвержденную программу, в которой нет группировки элементов, нажмите кнопку "Создать новую версию"

Поставьте галочку в чек-боксе «Группировать элементы»

В таблице Элементы программы нажмите кнопку "Заполнить элементы автоматически" → отобразились все темы и документы из прошлой версии программы

Создайте Блок1 и Блок2

Выберите первую тему и нажмите кнопку "Изменить блок", выберите Блок1 → выбранная тема переместилась в Блок1.

Выберите вторую тему и нажмите кнопку "Изменить блок", выберите Блок2 → выбранная тема переместилась в Блок2.

Выберите первый документ и нажмите кнопку "Изменить блок", выберите Блок1 → выбранный документ переместился в Блок1.

В новую версию программы возможно добавлять новые блоки, документы и темы.

Мои обучения (сгруппированные)

Нажмите пункт меню "Обучение", подпункт "Мои обучения (сгруппированные)" → Открылись все обучения пользователя

Темы и документ, которые были добавлены в блоки отображаются в блоках, документ, который не был добавлен в блок отображается как "Вне блока".

Если перейти в Мои обучения, то программа будет отображена обычным способом без блоков.

-

Уведомление руководителя об ознакомлении с документами сотрудниками подразделения

Руководитель может получать уведомления об ознакомлении с документами своими подчиненными сотрудниками. Для этого в настройках подразделения в окне "Редактор подразделения" необходимо установить отметку в поле "Получать уведомления об ознакомлениях"
А также настроить соответствующее задание в пункте меню "Назначенные задания".

Уведомления приходят руководителю подразделения по всем сотрудникам, которые добавлены в это подразделение.

odg_assist_5.0/модуль_обучение.1774424476.txt.gz · Последнее изменение: — veronika

Если не указано иное, содержимое этой вики предоставляется на условиях следующей лицензии: GNU Free Documentation License 1.3
GNU Free Documentation License 1.3 Donate Powered by PHP Valid HTML5 Valid CSS Driven by DokuWiki